Performance degradation and failing requests
Incident Report for SGS DIGICOMPLY LIVE STATUS
Postmortem

Root cause

Issues caused the problem:

  • very long transactions on database entities,
  • long processing of image extraction for posts that contains lot of chunks and images,
  • infinite processing of some image urls that not provide an input stream,
  • wrongly processed exceptions in post changed handler service.

Evaluation

2022/09/26 - No problem with acuiring new connections from database. Not connections that stay in 'idle in transaction' state forever. Application perfomance is back in normal state. All checks done.

Posted Sep 27, 2022 - 11:58 UTC

Resolved
System performance degredation on random requests. Completely failed or timeout requests to backend services.
Posted Sep 26, 2022 - 06:00 UTC